Le site dédié à l'Alfa Romeo 147
FAQFAQ RechercheRechercher MembresListe des Membres Carte des membresCarte S'enregistrerS'enregistrer Mon ProfilProfil Messagerie privée (MP)Se connecter pour vérifier ses messages privés ConnexionConnexion


[TUTO a classer] : diagnostiquer un debimètre ou vanne EGR
Aller à la page 1, 2, 3, 4  Suivante
 
Poster un nouveau sujet   Répondre au sujet    ALFA 147 France Index du Forum -> Entretien
Voir le sujet précédent :: Voir le sujet suivant  
Auteur Message
grise147



Inscrit le: 14 Oct 2007
Messages: 8256
Localisation: TOULOUSE !

MessagePosté le: 04 Jan 2011 23:55    Sujet du message: [TUTO a classer] : diagnostiquer un debimètre ou vanne EGR Répondre en citant

Bonjour à tous ..

Voici un récap concernant les codes défauts, et symptômes pour une Vanne EGR / débimetre

En effet, les codes défauts sont pas forcément vrai, il faut les valider aussi par l’interprétation des valeurs lues avec une « valise » ..

Je vais commencer par un petit récapitulatif sur le diag egr /débitmètre

D’abord 2 schémas pour montrer le circuit admission ( collecteur, debimetre , turbo, et … vanne EGR )





Lorsque la température du liquide de refroidissement est > 20C et que le régime moteur est compris entre 800 et 3500 tr/mn, la centrale de contrôle moteur pilote l'électrovanne EGR avec un signal à onde carrée.

La variation de ce signal permet à la bobine de l'EGR de déplacer un obturateur servant à réguler le flux de gaz brûlés, entre le collecteur d'échappement et le collecteur d'admission; on obtient ainsi deux résultats:

* diminution de la quantité d'air introduite
* baisse de la température de combustion (du fait de la présence de gaz inertes) d'où une réduction de la formation des NOx (oxydes d'azote).

La centrale d'injection est tenue constamment informée de la quantité de gaz recyclés grâce aux informations fournies par le débitmètre. En effet, si pour un régime donné, l'admission d'une certaine quantité d'air (Qam) est prévue et que la valeur fournie par le débitmètre (Qar) est inférieure, l'écart (Qgr) correspondra à la quantité de gaz recyclés.

Qam - Qar = Qgr

Qam = quantité d'air théorique mémorisée

Qar = quantité d'air effective

Qgr = quantité de gaz recyclés

Attention le signal de pression atmosphérique est utilisé dans le pilotage de l'électrovanne EGR pour identifier les conditions de fonctionnement en altitude, de façon à réduire la quantité de gaz recyclé et éviter les rejets de fumées du moteur.

Ce système permet de diriger vers l'admission une partie (5 à 15%) des gaz d'échappement, dans des conditions de fonctionnement bien déterminées.

De cette façon, on abaisse le pic de température dans la chambre de combustion, ce qui limite la formation des oxydes d'azote (NOx).
Un échangeur de chaleur (3) permet le refroidissement partiel des gaz d'échappement en augmentant le rendement volumétrique du moteur.

pour démarrer le diagnostic, il faut les paramètres suivants

- Température ambiante supérieure à 18°C (valeurs lues par la sonde de température d''air sur le débitmètre)

Et aussi, il ne faut pas les codes défauts suivants pour le contrôle avec l'électrovanne EGR ouverte

- P0045 - P0069 - P0100 - P0101 - P010F - P0111 - P0235 - P0401 - P0402 - P0403 - P060B - P0651 - P2004 - P2008 - P2009 - P2010 - P2011 - P2012 - P2013 - P2108 - P2112 - P2226 - P2620

doivent être absentes, car la stratégie de rétablissement (Recovery) de la centrale de contrôle du moteur intervient sur la commande EGR, en amenant la valeur d'ouverture de l'électrovanne à <5% (position de fermeture) jusqu'à la résolution de l'erreur (de présente à intermittente).

Sur les versions avec filtre à particules (DPF), l'erreur P1206 doit être absente

PREMIER TEST :

Brancher l'examiner ou FiatECUScan et le préparer à la lecture et à la mesure des paramètres suivants:
- Régime du moteur
- Masse d'air mesurée (valeurs correctes figurant dans la table 1)
- Masse d'air nominale (valeur calculée par la centrale)
- Température du liquide du moteur (>= 90°C)
- Ouverture de l'électrovanne EGR (valeurs correctes figurant dans la table 1)
- Position de l'accélérateur (mini = 0%; maxi à vide = 100%)

Démarrer le moteur et attendre que la température du liquide de refroidissement du moteur soit >= 90 °C

Et une fois à une température supérieure ou égale à 90 °C sans charges activées (ventilateur de refroidissement, climatiseur, feux, etc.), mesures la masse d'air en réunissant les conditions suivantes :
- au ralenti, électrovanne EGR fermée (ouverture soupape EGR < 5%)
- au ralenti, électrovanne EGR ouverte* (ouverture électrovanne EGR = 30% ÷ 55%)

Pour passer de la condition de fermeture de l'électrovanne EGR à celle d'ouverture, appuis légèrement sur la pédale d'accélérateur, puis relâches la pour revenir au ralenti (l'électrovanne EGR ne s'ouvrira que pour une durée de 70 secondes environ, pour se refermer ensuite si la pédale d'accélérateur n'est plus actionnée)

Vérifier les valeurs de masse d'air mesurées dans les différentes conditions et comparer avec le tableau ci dessous.
- moteur au ralenti EGR ouvert 30 à 55 % : masse d'air mesurée = 250 à 325 pour un 150 ch (1.9 jtd16 150ch)
- moteur au ralenti EGR fermé <5 : masse d'air mesurée = 400 à 530 pour un 150 ch(1.9 jtd16 150ch)



DEUXIEME TEST :




TROISIEME TEST :

Si tous les tests ci-dessus ont rien fait, (avec les températures Air, altitude, et liquide correspondent aux valeurs « nominales » )

Il faut faire un diagnostic de l’hystérésis de l’électrovanne EGR

Pour cela, il faut que le moteur tourne et attendre la fermeture de la vanne EGR (moteur au ralenti pendant 70 sec mini )

- porter à 2000 tours de manière constante à vide
- attendre 3 sec (à 2000 tours )
- lire en continu les valeurs d’ouverture EGR et mémoriser les mini / maxi lues
- revenir au ralenti et repartir de suite à 2000 tours et répéter la lecture
- vérifier la variation de la valeur :

Par exemple, valeur maxi lue 48 %, mini 46 % soit une variation de 2 %, et le deuxième test, maxi 43%, mini 33 % , soit une variation de 10 %

C’est pas la valeur qui est intéressante, mais le « delta » des valeurs

Couper le moteur

Si lors d’un des 2 essais moteur, l’oscillation de la commande EGR est supérieur à 5%, remplacer l’électrovanne, Sinon l’hystérésis de l’EGR est considéré comme normal

Bon diagnostic, celui-ci est très « lourd », n’hésitez pas à faire part de vos remarques, d’expériences afin d’enrichir ce tuto ..

[EDIT] la vanne EGR est condammable à 100% (fermeture simple par une tole pleine )sur EDC15 (soit JTd 115 ch et 100 ch)

la vanne EGR est bridable (fermeture simple par une tole perforée )sur EDC16 (soit JTd 120 ch, 126 ch , 140 ch, 150 et 170 ch) mais en aucun cas, on peut pas la condammer, sinon voyant MIL allumé (sauf reprogrammation de la centrale)


au_revoir


Dernière édition par grise147 le 01 Sep 2014 18:34; édité 7 fois
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé




grise147



Inscrit le: 14 Oct 2007
Messages: 8256
Localisation: TOULOUSE !

MessagePosté le: 09 Jan 2011 19:11    Sujet du message: Répondre en citant

Ajout de 2 paragraphes, concernant les codes defauts P1238

je pense que ca va interesser du monde .. clin_oeil
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
vinzebonz



Inscrit le: 13 Sep 2010
Messages: 14
Localisation: Est Vaucluse (84)

MessagePosté le: 17 Jan 2011 21:38    Sujet du message: Répondre en citant

Salut,

superbe tuto pour apprendre à mieux comprendre les mécanismes de cette organe !

Alors de mon côté, j'ai eu droit à mon voyant avarie gestion moteur après avoir eu de gros trous à bas régime. La voiture semble depuis plus molle à bas régime puis ça démarre bien vers 2300tr/min. Pas de sur-consommation.
Après diagnostic électronique chez mon garagiste, le verdict tombe :
P0401 - soupage RGE

Donc il décide de nettoyer la vanne qui était selon lui bien encrassée.
Au bout de 5 minutes de roulage, le voyant est de retour...
Je décide de nettoyer le capteur pression turbo, lui aussi bien encrassé. Légère amélioration mais toujours le problème du voyant et voiture assez molle à bas régime.
Je décide donc de m'équiper (cable+FiatECUscan) et de réaliser les mesures comme indiquée dans le tuto.
Voila ce que ça donne pour les paramètres masse d'air objectif et mesuré (en mg/i) et ouverture valve RGE (en %) :




Je précise que le paramètre contrôle RGE est toujours égal à OFF après effacement de l'erreur.

On voit bien sur la courbe que la vanne reste tout le temps à 4% de fonctionnement ce qui n'est pas normal surtout pendant les phases d'accélération.

Donc pour résumé : erreur P0401 + param. control EGR = OFF + fonctionnement = 4% à tout régime moteur.

J'en appelle donc à votre expertise pour m'aider à diagnostiquer ce problème. au_revoir

merci d'avance,
@+
_________________
alfa 147 JTDm 150 TI 5P
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
grise147



Inscrit le: 14 Oct 2007
Messages: 8256
Localisation: TOULOUSE !

MessagePosté le: 18 Jan 2011 09:01    Sujet du message: Répondre en citant

j ai du mal a lire les valeurs des abscisses et des ordonnées ..

en tous cas, a 1 endroit, on voit que la valeur lue depasse l'objectif

cette valeur veut dire vanne Grippée fermée ..

mais si elle est sur 4 % ou sur OFF et voyant MIL allumé, le calculo a essayé de la faire marcher mais il a abandonné

il faut refaire le test mais rapide, c est a dire éteindre le voyant, et refaire une lecture des paramètres avant le réallumage du voyant qui "tue" la gestion EGR

en tous cas, ca ressemble a une vanne HS (electrique ou soupape hs)
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
vinzebonz



Inscrit le: 13 Sep 2010
Messages: 14
Localisation: Est Vaucluse (84)

MessagePosté le: 18 Jan 2011 20:18    Sujet du message: Répondre en citant

Me revoila avec de nouvelles mesures comme demandé bounce

alors j'ai bien pris soin de vérifier qu'il n'y avait aucune erreur d'enregistrée dans le calculo avant de faire les mesures et voici ce que ça donne :



Donc la vanne fonctionne (entre 4 et 96%)
J'ai pu vérifier en temps-réel que le paramètre de controle était actif (il change d'état suivant la sollicitation).

Par contre, je ne comprend pas pourquoi la vanne est à 95% alors que le moteur est au ralenti à la fin de la courbe (à partir de 182s)...

C'est grave docteur ?
_________________
alfa 147 JTDm 150 TI 5P
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
aurel_50100



Inscrit le: 15 Fév 2010
Messages: 59
Localisation: Cherbourg

MessagePosté le: 18 Jan 2011 21:02    Sujet du message: Répondre en citant

Salut à tous!

Je vous explique brièvement mon histoire :

j'ai une 147 jtdm 150 de 2004 et totalisant 113000 Km.

Hier en partant du feu j'ai eu comme l'impression que j'allais caler, bon je me dit que je ne suis pas réveillé.

Ce matin je part d'un feu (sur une petite pente) et paf je cale! Ensuite aucune puissance moteur sous 2000 tr/min même pied au plancher rien!

Ce midi la voiture fonctionne correctement et ce soir c'est aléatoire!

Pour info aucune fumée et aucune avarie moteur à l'odb.

J'ai donc branché Fiatecuscan j'ai suivi le tuto apparemment il y a un mauvais fonctionnement de la vanne EGR.

J'ai nettoyer la vanne et le capteur de pression turbo il y a 15000Km.

Je n'ai aucun codes erreurs.

Je vous joint les données relevées!

[IMG]http://img13.imageshack.us/g/courbef.jpg/[/IMG]

Si il y a un motivé pour m'expliquer parce que je n'ai pas tous compris.

En effet j'ai l'impression de rentrer d'en plusieurs des cas expliqué par grise!


Merci par avance







clin_oeil
_________________
Quitte à se déplacer avec une voiture autant le faire dans une qui a de la gueule!
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
grise147



Inscrit le: 14 Oct 2007
Messages: 8256
Localisation: TOULOUSE !

MessagePosté le: 18 Jan 2011 21:20    Sujet du message: Répondre en citant

pour repondre a vincebonz

ca ressemble a une vanne qui coince, ouvert, des fois fermée

car, aparament, tu as des zones "jaunes" ou "bleues"



Uploaded with ImageShack.us

qui correspondent avec des tentatives de ouverture/fermeture de la vanne EGR mais elle suit mais pas a fond, on dirait qu elle a un decalage, du coup ta gestion moteur galere a suivre les "targets"

mon diagnostic (je decouvre un peu les principes des diags avec plusieurs lectures en temps reel, donc a prendre avec des pincettes):

- vanne EGR 80 %
- Commande turbo 10 %
- reste .... razz

ensuite, l EGR qui reste ouvert au ralenti, c est normal, le moteur cherche a depolluer au max ..

est ce que tu peux pas te faire preter une vanne EGR ?

PS : si tu peux faire un super tuto avec le relevé de mesure, ca serait top pour ce forum cool
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
grise147



Inscrit le: 14 Oct 2007
Messages: 8256
Localisation: TOULOUSE !

MessagePosté le: 18 Jan 2011 21:27    Sujet du message: Répondre en citant

@aurel50100

j ai du mal a lire tes images,

vite fait, ca ressemble a une vanne EGR HS

en fait, comme elle se grippe ouverte (EDC16C8 il me semble dans ton cas)
du coup, elle a pas de pattate,

mais le hic, tu as une image qui dit le contraire (valeur objectif superieure a la valeur lue)



j arrive pas a voir les graphiques de tes relevé de mesures

uen fois que chacun a trouvé la panne, je corrigerais ce tuto en premiere page afin que tout le monde puisse soi meme diagnostiquer

il faut savoir de pas mal de mecanos se plantent dans le diag, et qui est loin d etre evident ..



clin_oeil au_revoir
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
aurel_50100



Inscrit le: 15 Fév 2010
Messages: 59
Localisation: Cherbourg

MessagePosté le: 18 Jan 2011 21:35    Sujet du message: Répondre en citant

Merci grise pour cette réponse plus que rapide!

c'est bien ce que j'ai déduit :

J'ai les symptômes d'une vanne grippée ouverte mais les valeurs d'une vanne grippée fermée!!

Par contre grise je peux t'envoyer les photos par mail (si tu me la donne en MP).


En tous cas merci pour ta rapidité.
_________________
Quitte à se déplacer avec une voiture autant le faire dans une qui a de la gueule!
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
grise147



Inscrit le: 14 Oct 2007
Messages: 8256
Localisation: TOULOUSE !

MessagePosté le: 18 Jan 2011 21:40    Sujet du message: Répondre en citant

poste ta courbe via imageshack . clin_oeil
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
aurel_50100



Inscrit le: 15 Fév 2010
Messages: 59
Localisation: Cherbourg

MessagePosté le: 18 Jan 2011 22:12    Sujet du message: Répondre en citant

Donc en effet la courbe est dégueulasse désolé.



Par contre le tableau correspond à la courbe, on voit bien qu'au départ le fonctionnement parait normal. Au bout d'une trentaines de sec ça débloque ce qui explique pourquoi ça me le fait après un arrêt prolonger au feu!





Pour info ces relevés on été fait moteur chaud.

clin_oeil
_________________
Quitte à se déplacer avec une voiture autant le faire dans une qui a de la gueule!
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
grise147



Inscrit le: 14 Oct 2007
Messages: 8256
Localisation: TOULOUSE !

MessagePosté le: 18 Jan 2011 22:59    Sujet du message: Répondre en citant

aurel, je prefere que tu me refasse les courbes, car ok, je suis myope, mais la oh oh

j ai pas mon decodeur CANAL+ .... lol au_revoir
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
grise147



Inscrit le: 14 Oct 2007
Messages: 8256
Localisation: TOULOUSE !

MessagePosté le: 19 Jan 2011 14:27    Sujet du message: Répondre en citant

alors, j ai oublié de dire une info capitale ..

quand on nettoie une vanne EGR, il faut la nettoyer, certes

mais il faut contrôler l étanchéité, mais avec un fluide (gasoil par ex)

car si elle ferme mal ( il y a 2 soupapes dans une vanne EGR)

bin, c est pas la peine de la remettre .. clin_oeil au_revoir
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
aurel_50100



Inscrit le: 15 Fév 2010
Messages: 59
Localisation: Cherbourg

MessagePosté le: 19 Jan 2011 20:55    Sujet du message: Répondre en citant

Salut grise,

Pour ma par j'ai bien évidemment contrôlé l'étanchéité en premier.

Par contre aujourd'hui j'ai débranché la vanne et la voiture fonctionne correctement.

Je rebranche ma vanne ce wk j'ai un long trajet à faire ça vas peut être lui faire du bien.

Je refais une courbe, que je posterais, lundi soir.

Ciao clin_oeil
_________________
Quitte à se déplacer avec une voiture autant le faire dans une qui a de la gueule!
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
grise147



Inscrit le: 14 Oct 2007
Messages: 8256
Localisation: TOULOUSE !

MessagePosté le: 20 Jan 2011 21:45    Sujet du message: Répondre en citant

alors, pour info, je me relis, et plein de trucs vont pas sur ce TUTO ..

je suis en train de le reecrire et de chopper des docs "lourdes" pour enrichir parfaitement ce tuto ..

donc, je vous demande d attendre 10 j .. clin_oeil

et ceux qui ont pu resoudre leur panne, ca serait cool de me faire un retour d infos .. clin_oeil au_revoir
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
grise147



Inscrit le: 14 Oct 2007
Messages: 8256
Localisation: TOULOUSE !

MessagePosté le: 20 Jan 2011 22:58    Sujet du message: Répondre en citant

bon, j'ai bossé 4 heures afin d avoir un max d infos, et de recouper d'autres infos, et de tout réécrire et de clarifier le tuto, voila le resultat en premiere page ..

est ce que vous "comprenez " mieux ? lol

n'hésitez pas à faire part de vos remarques .. clin_oeil cool
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
MiKL



Inscrit le: 11 Déc 2003
Messages: 29042
Localisation: Les Hauts de Cergy Val d'Oise France

MessagePosté le: 21 Jan 2011 00:25    Sujet du message: Répondre en citant

grise147 a écrit:
bon, j'ai bossé 4 heures afin d avoir un max d infos, et de recouper d'autres infos, et de tout réécrire et de clarifier le tuto, voila le resultat en premiere page ..

est ce que vous "comprenez " mieux ? lol

n'hésitez pas à faire part de vos remarques .. clin_oeil cool


beau boulot ;-) Merci bien ;-)
par contre surpris que les valeurs du 2.4 20V ne soient pas les mêmes entre la croma et la 159... oh
_________________
Golf GTE + 147 selespeed Ti et 156 GTA de Deydey ;-)
EX : Giulietta 1.4 MultiAir TCT Executive Rouge Alfa TOE Panoramique Duplex O--O Ragazzon H2 Vrooom
Ex : 159 SW 2.4 JTD Selective (Dist. Corporate) reprog/Défap/EGR out
EX : 147 T.S. 150 Selespeed Select. Noire Cuir rouge 17' Supersport Nav+ TOE CSC Radar Recul 6000°K et 4 Koni FSD ;-)
EX : 147 T.S. 120 Dist. Bleu Inca Int. cuir gris CSC
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web du posteur MSN Messenger
grise147



Inscrit le: 14 Oct 2007
Messages: 8256
Localisation: TOULOUSE !

MessagePosté le: 21 Jan 2011 09:06    Sujet du message: Répondre en citant

ouias, je pense pour le 2.4, ce sont les normes de antipollution (CF3, CF4 et CF5) qui doivent avoir un flux EGR plus important ? clin_oeil au_revoir

regarde le tableau avec les EGR fermé ouverte, on voit de suite que quand c est fermé, c est le même debit d air .

j ai corrigé le tableu du test N°2 ( il manquait les designations des colonnes) au_revoir
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
vinzebonz



Inscrit le: 13 Sep 2010
Messages: 14
Localisation: Est Vaucluse (84)

MessagePosté le: 24 Jan 2011 21:49    Sujet du message: Répondre en citant

tada !

Et voila les courbes fraîches du jour !

Donc départ avec valve à 4% d'ouverture, moteur chaud (83°), clim. éteinte, feux éteint (enfin juste les xénons car tests faits au bord de la route et de nuit...).
J'ai bien sur effacé pour la nième fois le code erreur vanne EGR avant de commencer les tests.

Début des tests avec masse d'air mesurée OK.
Petit coup d'accélérateur, la vanne s'ouvre, puis s'ouvre, n'en finit pas de vouloir s'ouvrir jusqu'à 95% ! La masse d'air mesurée diminue un peu au début mais reste largement excessive par la suite.
Au bout de 70s, comme prévu retour à 4%

Procédure réalisée 3 fois. Au milieu du 3ème plateau (309s), je pense que l'erreur habituelle s'est déclenchée vu le retour prématuré à 4% puis plus de signe de vie malgré les sollicatations (voir courbes). Hypothèse confirmée dans l'onglet "erreurs".

Donc d'après le tuto, j'en déduis que la vanne est grippée donc à changer.
Je n'ai du coup pas fait le 3ème test d'hysteresis.

Une question concernant l'erreur affiché avec fiatECUscan : que signifie "signal faible" ?

à vous les studios,
@+




_________________
alfa 147 JTDm 150 TI 5P
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
grise147



Inscrit le: 14 Oct 2007
Messages: 8256
Localisation: TOULOUSE !

MessagePosté le: 24 Jan 2011 21:56    Sujet du message: Répondre en citant

alors, dans ton cas, des que une vanne EGR depasse 65 % de pilotage, c est que le calculo arrive plus a la faire ouvrir selon les carto prevues ..

donc, a changer..

aussi, "signal faible" peut etre qu il faut interpreter ca avec un bobinage coupé de la vanne EGR ? au_revoir

tiens nous au courant de ta panne afin d enrichir ce tuto .. razz
Revenir en haut
Voir le profil de l'utilisateur Envoyer un message privé
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    ALFA 147 France Index du Forum -> Entretien Toutes les heures sont au format GMT + 2 Heures
Aller à la page 1, 2, 3, 4  Suivante
Page 1 sur 4



 
Sauter vers:  
Vous ne pouvez pas poster de nouveaux sujets dans ce forum
Vous ne pouvez pas répondre aux sujets dans ce forum
Vous ne pouvez pas éditer vos messages dans ce forum
Vous ne pouvez pas supprimer vos messages dans ce forum
Vous ne pouvez pas voter dans les sondages de ce forum





ok